Syclone #2236 is on jackstands again :)

Looks good. I keep looking @ mine in the garage. Trying to figure out if it's time to punt or put the time in to get it running.

I agree with @Sy2622. If it makes it any better, the First owner of my truck, owns a beautiful Shelby GT 500. He had them parked together in his Garage for a number of years. Theres just something about the character of these trucks that even someone with a GT 500 can't resist. I know that guy would love to have a Syclone in his garage again if his wife would let him. Heres a picture of his two trucks back in, I think, 1999?
 

Attachments

  • IMG_E6655[1].JPG
    IMG_E6655[1].JPG
    1.3 MB · Views: 14

4C FED

Absolutum Dominium
I agree with @Sy2622. If it makes it any better, the First owner of my truck, owns a beautiful Shelby GT 500. He had them parked together in his Garage for a number of years. Theres just something about the character of these trucks that even someone with a GT 500 can't resist. I know that guy would love to have a Syclone in his garage again if his wife would let him. Heres a picture of his two trucks back in, I think, 1999?

Just sooo many things going on all the time. Always seem to be working on my daily driver or my G8, wife's car, kids car or around the house.
Here's my version, last time I cleaned the garage...

sy & ty.jpg
 

DaveP's Ghost

Active member
Picture day? This one is from my back porch in Fall of 2013.

There are 3 Syclones and one Typhoon in this view. The Ty is in the background under its cover, the third Sy is in the trailer. I don't remember what's in the garage, but something is because the C4 is outside. The F150 Harley truck wasn't mine. The SS 396 El Camino is gone now. So are the Syclones in the foreground. I still drive the red 91 S-10 daily, although it doesn't look very good anymore.IMG_2675.jpg
 

Jay92Ty

Donating Member
WOW..what a sight!:love:(y)
Love that Aqua color on the back of this Sy and especially the way they matched the wheels. So cool!
 

Jay92Ty

Donating Member
... oil smelled burnt and 2nd gear lost power. TV cable seems to have been slipping ( teeth on clicker weren't holding) at the throttle body.
maybe refill with new oil/filter and put a new tv cable if that one isn't working and drive it to see how it feels.
 

Goodgollyjosh

Active member
If you need a new TV cable, to my knowledge, the only one available is through sports machines. Take a look at the clocking of the end that goes in the transmission. I felt like the plastic housing was crimped slightly off from where it should have been. I bought two from them and they both had this issue. It would not sit flat in the transmission even when bolted in place. I tried playing with the routing of the cable but to no avail.

kickdown resized.png
 

wildphil

I Love My Ty's
... oil smelled burnt and 2nd gear lost power. TV cable seems to have been slipping ( teeth on clicker weren't holding) at the throttle body.
maybe refill with new oil/filter and put a new tv cable if that one isn't working and drive it to see how it feels.
Well if the fluid smelled burnt it will probably not be going much longer. Is it slipping in 2nd gear? Like the vehicle not moving faster when the throttle pedal is pushed down, only higher engine rpm? Yeah if that is the case. It is time to rebuild for sure.
 
Well if the fluid smelled burnt it will probably not be going much longer. Is it slipping in 2nd gear? Like the vehicle not moving faster when the throttle pedal is pushed down, only higher engine rpm? Yeah if that is the case. It is time to rebuild for sure.
I'm going to change the filter out, and add fresh fluid. I don't believe it will change anything, but if the trans is a goner, I'm close to home and can load it on the trailer and bring it back.

Now that I'm thinking about it, your comment got me thinking, shifting from 1-2 occurred right around 2100rpm before this issue. When I was texting @Jay92Ty I think I may have stated something incorrectly. There isn't complete power loss if I manually set the truck in second gear, its like the trans wont even shift into second. Rather it continually raises in rpm in first. As of now with the truck in D or OD, it feels like it skips second, and shifts into 3rd instead, at right around 2800-3100rpm.

If the Trans is trashed, it is what it is. Despite loosing second gear, it got me to Laguna Seca raceway and home. Almost 400 miles, I put a beating on her for sure, and its time to pay back my dues.
 
Last edited:
Short update here for 2236. Tranny is indeed a goner unfortunately and I've decided I will be prepping the truck for a 4L80E conversion. Also I will be installing a slightly modified (With the stock cam) freshly rebuilt engine from Sy #2053 once I'm done with the 4L80E conversion. Exact specs for what I decide to go with on Sy 2053's engine will be posted later down the line.

It'll take some time, but I believe I should be back on the road in at most 6-8 years. HAHA. We'll see how things go though!
 
Top