Coolant leak/weep

Slyclone

Active member
Noticing a small coolant leak at the front driver side block/lower intake area. It appears to be a little wet looking down the cylinder head towards the rear of the block.

Wondering what I did, or didn't do right. Actually coming from right under the dual eyelets connectors/grounds. I'd post photos but every time I try it says too large of files.
 

gmemony2

New member
You should be able to post your photos to a place like Photobucket or Imgur and use the links they provide to show photos here.
 
Noticing a small coolant leak at the front driver side block/lower intake area. It appears to be a little wet looking down the cylinder head towards the rear of the block.

Wondering what I did, or didn't do right. Actually coming from right under the dual eyelets connectors/grounds. I'd post photos but every time I try it says too large of files.

That sounds similar to an issue I was having, after I replaced my thermostat gasket. Your problem may not be the same, but I would check this. When you're pushing the upper radiator hose down onto the metallic inlet, there is an indent that will indicate where the face of the hose should sit. I accidentally pushed my hose over the top of the indent and past it. So, when I started the truck up the first time, I had coolant leak from the front hose, over the top of the lower intake. All you have to do is loosen your hose clamp, pull the hose back over the indent. Then seat the hose right at the indent, and tighten the hose clamp accordingly. Easy mistake to make, but also an easy fix, as long as you're not driving along.
 

Slyclone

Active member
I will look tomorrow thanks for the input could be something very small I overlooked hopefully that's the case it's been a on-off thing the past couple years. I found out I didn't tighten quite a few things and I'm doing, and re-doing the work once again.
 
Top